Back
Degraded

Intermittent Degraded Performance
Started 2 Nov at 05:20pm UTC, resolved 3 Nov at 06:13pm UTC.
Online ordering
Resolved
The transitory issue affecting our services has been resolved by the upstream provider. Observed downtime: 5 minutes @ 2 Nov 2023 at 02:57am HDT and 2 minutes at 2 Nov at 07:24am HDT
Posted 3 Nov at 06:13pm UTC.

Created
We appear to be facing upstream degraded performance. Tracking in https://www.cloudflarestatus.com/incidents/hm7491k53ppg.
Posted 2 Nov at 05:20pm UTC.