Get in touch
Back
Maintenance

Update maintenance

Completed 20 Feb at 11:30pm UTC.

Online ordering Restaurant Dashboard
Completed

Maintenance completed

Posted 20 Feb at 11:30pm UTC.
Started

Performance upgrades and dashboard refresh.

Posted 20 Feb at 09:10pm UTC.